Just updated recently to the new FF3.1b2 but a lot of my extensions were not compatible.

You can get around this - at your own risk - by installing the Nightly Tester Tools extension

This give you a right click menu to override the compatibility warnings and run the extensions anyway.